CCNP路由试验---1、EIGRP的根本装备51CTO博客 - 超凡娱乐

CCNP路由试验---1、EIGRP的根本装备51CTO博客

2019年02月26日09时57分45秒 | 作者: 君昊 | 标签: 装备,路由,试验 | 浏览: 2546

CCNP路由试验-1、EIGRP的根本装备

一、试验意图

1、把握EIGRP的根本装备。

2、把握EIGRP的通配符掩装备办法。

3、把握EIGRP的主动汇总特性,以及怎么封闭主动汇总。

4、把握EIGRP的手艺汇总。

二、试验拓扑

试验过程:

1、装备各路由器的称号、相连接口IP地址;

R1(config)#int s1/1

R1(config-if)#ip add 172.16.1.1 255.255.255.252

R1(config-if)#no shut

R1(config)#int loopback 0

R1(config-if)#ip add 10.1.0.1 255.255.255.0

R1(config-if)#int loopback 1              

R1(config-if)#ip add 10.1.1.1 255.255.255.0

R1(config-if)#int loopback 2              

R1(config-if)#ip add 10.1.2.1 255.255.255.0

R1(config-if)#int loopback 3              

R1(config-if)#ip add 10.1.3.1 255.255.255.0

 其它R2R3相似进行装备。装备完后用ping指令承认各路由器的直连口的互通性。

2、  装备EIGRP协议,设置自治体系号为80

R1

R1(config)#router eigrp 80

R1(config-router)#network 172.16.0.0

R2

R2(config)#router eigrp 80

R2(config-router)#network 172.16.0.0

R2(config-router)#network 111.111.0.0

R3

R3(config)#router eigrp 80

R3(config-router)#network 172.16.0.0

   补白:通常在路由器上装备EIGRP宣告通路网络时运用两种办法,办法1network +主类网络号,这样能够将路由器上相关地址的接口直接加入到EIGRP路由进程中去;办法2:运用通配符掩码进行装备,例如network X.X.X.X 0.0.0.X。这儿先用榜首种办法试验,后边将运用第二种办法试验。

3、  至此,EIGRP现已装备好,下面进行验证了。

4、  首要在各路由器上检查是否现已树立EIGRP的街坊联系:

R2#sh ip eigrp 80 nei

IP-EIGRP neighbors for process 80

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   172.16.1.6              Se1/2             12 00:00:40    1  3000  0  2

0   172.16.1.1              Se1/0             12 00:03:41    1  4500  0  2

补白:列H指出街坊学习的次序,Address指出街坊地址;Interface指出街坊地点本地接口;Hold Uptime表明等候没有从街坊那里接纳到任何包的最大时刻.当接受到新的包今后,holdtimer复位;RTO(RetransmitTimeOut):单位是毫秒,表明路由器在从头传输包之前等候ACK的时刻;QCnt:等候发送的排队摆放的包.假如这个值继续高于0的话,阐明发生了拥塞问题。

5、  检查路由表。

R2#sh ip route 

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

C       172.16.1.4/30 is directly connected, Serial1/2

D       172.16.0.0/16 is a summary, 00:28:58, Null0

C       172.16.1.0/30 is directly connected, Serial1/0

D    10.0.0.0/8 [90/2297856] via 172.16.1.1, 00:06:20, Serial1/0

C    111.111.0.0/16 is directly connected, Loopback0

D    192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:05:43, Serial1/2

补白:EUGRP会主动的对子网进行汇总生成一条指向null0的路由,是为了防止环回路由。前面标D表明是EIGRP路由,[90/2297856]中的90EIGRP的内部管理间隔,2297856表明EIGRP核算的度量值(FD)。

假如只想看EIGRP的路由进程,能够运用指令:show  ip route eigrp

R2#sh ip route eigrp

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

D       172.16.0.0/16 is a summary, 00:34:39, Null0

D    10.0.0.0/8 [90/2297856] via 172.16.1.1, 00:12:01, Serial1/0

D    192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:11:24, Serial1/2

6、  从上面R2的路由表中调查到有一条指向s1/0口的10.0.0.0/8的汇总路由,这是EIGRP路由协议主动汇总的特性表现。能够运用no auto-summary指令封闭它。

首要是在R1进行封闭。

R1(config)#router eigrp 80

R1(config-router)#no au

R1(config-router)#no auto-summary

然后再次调查R2的路由表

R2#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     172.16.0.0/30 is subnetted, 2 subnets

C       172.16.1.4 is directly connected, Serial1/2

C       172.16.1.0 is directly connected, Serial1/0

     10.0.0.0/24 is subnetted, 4 subnets

D       10.1.3.0 [90/2297856] via 172.16.1.1, 00:00:01, Serial1/0

D       10.1.2.0 [90/2297856] via 172.16.1.1, 00:00:01, Serial1/0

D       10.1.1.0 [90/2297856] via 172.16.1.1, 00:00:01, Serial1/0

D       10.1.4.0 [90/2297856] via 172.16.1.1, 00:00:01, Serial1/0

C    111.111.0.0/16 is directly connected, Loopback0

D    192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:11:27, Serial1/2

补白:当运用no auto-summary指令封闭EIGRP的主动汇总之后,再次检查R2的路由表能够到有关汇总为10.0.0.0/8前的详细路由了。

7、  EIGRP还能够人工设置地址汇总。人工设置地址汇总,也能够有用的削减路由表的巨细。比如在R2上的路由中关于R3192.168.*.*的网络显现为四条详细路由:

D    192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:05:09, Serial1/1

D    192.168.1.0/24 [90/2297856] via 172.16.1.6, 00:05:09, Serial1/1

D    192.168.2.0/24 [90/2297856] via 172.16.1.6, 00:05:09, Serial1/1

D    192.168.3.0/24 [90/2297856] via 172.16.1.6, 00:05:09, Serial1/1

能够在R3上进行如下装备,削减路由布告条目。

R3(config)#int s1/1

R3(config-if)#ip summary eigrp 80 192.168.0.0 255.255.252.0

随后再检查R2的路由表

R2#sh ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     172.16.0.0/30 is subnetted, 2 subnets

C       172.16.1.4 is directly connected, Serial1/2

C       172.16.1.0 is directly connected, Serial1/0

     10.0.0.0/24 is subnetted, 4 subnets

D       10.1.3.0 [90/2297856] via 172.16.1.1, 00:19:33, Serial1/0

D       10.1.2.0 [90/2297856] via 172.16.1.1, 00:19:33, Serial1/0

D       10.1.1.0 [90/2297856] via 172.16.1.1, 00:19:33, Serial1/0

D       10.1.4.0 [90/2297856] via 172.16.1.1, 00:19:33, Serial1/0

C    111.111.0.0/16 is directly connected, Loopback0

D    192.168.0.0/22 [90/2297856] via 172.16.1.6, 00:00:26, Serial1/2

补白:能够看到最终一条路由汇总成了

D    192.168.0.0/22 [90/2297856] via 172.16.1.6, 00:00:26, Serial1/2

8、  前面说过有两种办法能够装备EIGRP宣告通路网络,所以现在说下第二种办法———运用通配符进行装备EIGRP。例如R2上运用通配符掩码进行装备EIGRP,

首要删去之前所运用网络号装备的EIGRP,运用指令

R2(config)#no router eigrp 80

然后从头在R2上装备EIGRP

R2(config)#router eigrp 80

R2(config-router)#networ

R2(config-router)#network 172.16.1.0 0.0.0.3 

R2(config-router)#network 111.111.0.0

    补白:运用通配符掩码装备EIGRP,长处是能够很好的控制在哪些接口加入到EIGRP的进程中。不然的话或许需求运用passive-interface指令进行设置。此处仅将s1/2接口加入到eigrp中,所以R2s1/2接口,和R3的路由不会被转发给R1.

   再检查一下R2 的街坊表

R2#show ip eigrp neighbors

IP-EIGRP neighbors for process 80

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                                 (sec)         (ms)       Cnt Num

0   172.16.1.1              Se1/0             12 00:04:57 1510  5000  0  5

     此刻能够看到R2只与R1树立了街坊联系。

     再检查R1路由表

R1#show ip route eigrp

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

 D       172.16.0.0/16 is a summary, 00:02:55, Null0

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks

 D       10.0.0.0/8 is a summary, 00:02:55, Null0

 D    111.111.0.0/16 [90/2297856] via 172.16.1.2, 00:00:06, Serial1/1

     能够看到R1 只学习到了R2的路由项,而学到不到R3的路由。也就是说选用通配符掩码,进行选择性的装备,使得R1仅学习到131.131.0.0/16的路由条目。无法学习到R3的直接路由。

 

版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表超凡娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章